Wednesday, 1 May 2019

EIGRP Description and Configuration

EIGRP

Description

EIGRP ( Enhanced Interior Gateway Routing Protocol ) is a distance Vector routing Protocol. It is a successor of IGRP which was also a classless Routing Protocol . The Routing Protocol is a Cisco proprietary protocol. EIGRP doesn't send messages using UDP or TCP because it uses Cisco Protocol known as RTP (Reliable Transport Protocol). The protocol uses AS (Autonomous System) number for routing in the same domain of EIGRP Routers. The purpose of using this protocol is to transfer EIGRP packets between EIGRP routers. The protocol uses a combination of variety of metrics to choose the best route for routing. Following are the metrics used by EIGRP to choose the best path which are written below :
  • Bandwidth
  • Delay 
  • Load (opt)
  • MTU (Maximum Transmission Unit)  (opt)
  • Reliability (opt)
EIGRP uses mostly bandwidth and Delay but if EIGRP founds two path with same metric then MTU is used for tie-breaking.

EIGRP packets Type

EIGRP use 5 types of packets which are as follows

  • HELLO Packets (This packet is used for Discovery of Neighbors and to form adjacency).
  • UPDATE Packets (This packet is used to spread and promote Routing Information).
  • ACKNOWLEDGEMENT Packets (This packet is use for acknowledging the receipt of update,query and reply packets).
  • QUERY packets (This packet is used by DUAL homing for searching of networks for Unicasting and Multicasting).
  • REPLY packets (This packet used by DUAL homing for searching of networks for Unicasting).

 Configuration

Now take two PC's and two routers. Connect each pc with each router with a crossover cable on Gigabit interface and connect both router with a serial cable on serial interfaces .






Now assign IP addresses to each PC by clicking on the PC , going in the desktop Tab area and onto the IP configuration option as shown below





Now go to router and assign IP addresses to each router Gigabit and serial port and enabling them. After enabling the ports configure each router with EIGRP protocol. When configuring EIGRP, we will use the same AS number on each EIGRP router. remember EIGRP routers with different AS number cannot be used for packet routing. The configuration of both routers are shown below  

For Router 2 

Enabling Interfaces and Assigning IP to interfaces

Router>enable
Router#config terminal
Router(config)#interface gigabit 0/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial 0/1/0
Router(config-if)#ip address 192.168.6.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#

EIGRP Configuration

 

Router>enable
Router#config terminal
Router(config)#router Eigrp 5
Router(config-router)#network 192.168.3.0
Router(config-router)#network 192.168.6.0
Router(config-router)#exit
Router(config)#


For Router3

Enabling Interfaces and Assigning IP addresses to interfaces

Router>enable
Router#config terminal
Router(config)#interface gigabit 0/0
Router(config-if)#ip address 192.168.5.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 192.168.6.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#

 

EIGRP Configuration

 

Router>enable
Router#config terminal
Router(config)#router Eigrp 5
Router(config-router)#network 192.168.5.0
Router(config-router)#network 192.168.6.0
Router(config-router)#exit
Router(config)#

Now go to PC0 command prompt and ping the IP address of PC1. If you receive the reply from PC1 then your protocol  is working as shown below:


 


Monday, 6 November 2017

InterVLAN routing (Multilayer Switch)

Introduction

A Multilayer switch also known as a Layer 3 switch is a device that performs the function of a switch as well as a router also. The multilayer switch has the ability to operate at higher layers.  It can perform both Layer 2 and layer 3 functions at extremely fast speed. This is also a great option for us if we want to perform InterVLAN routing. In a Multilayer Switch, the VLAN interface acts as a router interface having an IP address and a subnet mask. The configuration of a multilayer switch is very easy and simpler as compared to a Router-On-A-Stick(ROAS).

Now take 2 PC's and a MultiLayer switch and connect it using a straight cable. Connect PC1 with interface fa 0/3 and PC2 with interface fa 0/5.

Now the first step is to vlan 3 and vlan 5 and assign vlan's to interfaces fa 0/3  and fa 0/5
switch(config)# vlan 3
switch(config-vlan)# name vlan03
switch(config-vlan)# exit
switch(config)# vlan 5
switch(config-vlan)# name vlan05
switch(config-vlan)# exit
switch(config)# interface fa 0/3
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan 3
switch(config-if)# exit
switch(config)# interface fa 0/5
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan 5

Now after you have made access ports to interfaces, it's time to assign IP address to vlan 3 and vlan 5

switch(config)# interface vlan 3
switch(config-if)# ip address 192.168.3.1 255.255.255.0
switch(config-if)# exit
switch(config)# interface vlan 5
switch(config-if)# ip address 192.168.5.1 255.255.255.0
switch(config-if)# exit

The last command helps to perform routing in a multilayer switch. Without this command, the packets cannot be routed in a multilayer switch.

switch(config)# ip routing

Now we assign IP adresses to PC1 and PC2 as shown below




Note that the default gateways of both the PC's contains the same IP address that we have given to VLAN interfaces. Now if we ping PC2 from PC1, we get the reply.











Sunday, 5 November 2017

Introduction to DHCP Part 2

DHCP Configuration

The DHCP is configured on a router. We then also state that router as a DHCP server. Remember that from a subnet, you must assign DHCP lease range that starts from .101 till .254 ( for example like 192.168.0.101 till 192.168.0.254). The range till 100 is used for static IP addressing such as those IP addresses that are given to switches, gateways, VLAN's, DNS servers etc. This is a standard way for using DHCP and is performed by many companies in the world.

To enable dhcp server you must write the following command on the router :
Ip dhcp pool name of pool

DHCP server settings

Following are the settings that we need to make on a DHCP server .
 
The subnet ID and the mask
The DHCP server needs to know all the addresses in the subnet.

Reserved addresses
Addresses that are reserved or excluded from the DHCP server which are needed to be used for static IP addressing. The command that is used for reserved addresses is :
ip dhcp excluded-address lowest address highest address

Default-router
The IP address of the router which is being used on that subnet.

DNS IP address
The IP address which is giving to a DNS server in the network.

Now take 2 PC's, 1 switch and 1 router. Connect the PC's and router with the switch using a straight cable as shown below

Now for the configuration
Router(config)# ip dhcp pool network
Router(dhcp-config)# network 192.168.5.0 255.255.255.0
Router(dhcp-config)# default-router 192.168.5.1 
Router(dhcp-config)# dns-server 192.168.5.5
Router(dhcp-config)# exit

Now again go to config mode so we can write the command for reserve static IP addresses

Router(config)# ip dhcp excluded-address 192.168.5.1 192.168.5.100

Now go to router interface 0/0 and assign the IP address to the interface which you have also given to the default router in the DHCP settings too.

 Router(config)# interface fa 0/0
 Router(config-if)# ip address 192.168.5.1 255.255.255.0
 Router(config-if)# no shutdown

Now go to PC1 and PC2 and click on DHCP in IP configuration


You can see that the IP address, subnet mask, default gateway and DNS server has been assigned dynamically by the DHCP successfully.